Helm Chart Chart.yaml

From NovaOrdis Knowledge Base
Jump to: navigation, search

External

Internal

Overview


Revised for Helm 3


The chart's main metadata file. It is required to be present. Some of the required and optional elements are presented below, unknown elements will be silently ignored.

Example

apiVersion: v2
name: archaeopteryx
version: 0.1.0
appVersion: "1.0"
description: archaeopteryx Helm chart

Elements

All fields below are available in templates as built-in objects, with their first letter capitalized and prefixed by ".Chart."

Example:

{{ .Chart.Name }}
For more details see:
Helm Templates

apiVersion

Required element; the chart API version. The apiVersion field should be "v2" for charts that require at least Helm 3. Charts supporting previous Helm versions have an apiVersion set to v1 and are still installable by Helm 3.

name

Required element. Represents the name of the chart.

version

Required element. Represents the SemVer 2 chart version number. Non-SemVer names are explicitly disallowed by the system. For more details, see
Chart Versioning

appVersion

Optional element. Represents the application version: the version of the application packaged in this chart. It does not need to be SemVer 2. For more details, see
Chart Versioning

dependencies

dependencies is an optional element that contains the list of immediate (direct) dependencies for this chart, expressed as a list of chart "coordinates": name, version and repository URL. Note that the immediate dependencies might have dependencies on their own, which are not explicitly specified in the chart's requirements.yaml file. Helm does not walk the dependency tree the same way like, for example, Maven does, but well formed Helm charts include recursively their own dependencies, so this is usually not a problem. For an in-depth discussion on how Helm dependencies work, see:
How Helm Dependencies Work

The dependencies element was introduced in Helm 3 and replaces the requirements.yaml file.

dependencies:
  - name: a # The name of the dependency
    version: # The version of the dependency
    repository: # Repository URL
    condition: a.enabled, global.a.enabled
    tags:
      - front-end
      - a
For more details about the element's syntax, see:
Helm Dependencies

kubeVersion

Optional element. A SemVer range of compatible Kubernetes versions.

description

Optional element; the single-sentence description of this project.

type

Optional element. See:
Chart Type

keywords

home

sources

maintainers

engine

icon

deprecated

TODO: https://helm.sh/docs/topics/charts/#deprecating-charts.